p PatchFirst

CVE-2026-40864

CVE-2026-40864 · JupyterHub: Cross-origin form POSTs bypass XSRF

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. In versions 4.1.0 through 5.4.4, XSRF protection (updated in 4.1.0) inappropriately treated requests with Sec-Fetch-Mode: no-cors as same-origin requests, bypassing XSRF checks. The JSON API is not affected, only HTTP form endpoints, such as /hub/spawn and /hub/accept-share, meaning attackers could trigger server spawn (but not access the server) and if the attacker is a JupyterHub user permitted to share access to their server, cause a user to accept a share and have access to the attacker's server. This issue has been fixed in version 5.4.5. If developers are unable to immediately upgrade, they can temporarily mitigate this issue by dropping requests to JupyterHub with Sec-Fetch-Mode: no-cors if they are using a reverse proxy.

CVSS 5.4 · Средний · EPSS 0,1% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • jupyterhub

    Версии
    • >= 4.1.0, < 5.4.5: Затронуто

    Нет опубликованного исправления

  • jupyterhub Debian:13

    Версии
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyterhub Debian:14

    Версии
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyterhub PyPI

    Версии
    • 4.1.0
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.1.4
    • 4.1.5
    • 4.1.6
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.1.0
    • 5.2.0
    • 5.2.1
    • 5.3.0
    • 5.3.0rc0
    • 5.4.0
    • 5.4.1
    • 5.4.2
    • 5.4.3
    • 5.4.4
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.1.0, < 5.4.5

    Обновитесь до 5.4.5

  • jupyterhub Ubuntu:22.04:LTS

    Версии
    • 2.0.0+ds1-1
    • 2.0.0+ds1-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyterhub Ubuntu:24.04:LTS

    Версии
    • 3.0.0+ds1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyterhub Ubuntu:25.10

    Версии
    • 5.2.1+ds1-2
    • 5.2.1+ds1-3
    • 5.2.1+ds1-4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyterhub Ubuntu:26.10

    Версии
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyterhub Ubuntu:26.04:LTS

    Версии
    • 5.2.1+ds1-4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →