CVE-2026-41423
CVE-2026-41423 · Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR). When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions. Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This issue has been patched in versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8.
CVSS 8.7 · Высокий · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
angular
- Версии
- < 19.2.21: Затронуто
- >= 20.0.0-next.0, < 20.3.19: Затронуто
- >= 21.0.0-next.0, < 21.2.9: Затронуто
- >= 22.0.0-next.0, < 22.0.0-next.8: Затронуто
Нет опубликованного исправления
angular.js Debian:12
- Версии
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Debian:13
- Версии
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 22.0.0-next.0, < 22.0.0-next.8
Обновитесь до 22.0.0-next.8
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 21.0.0-next.0, < 21.2.9
Обновитесь до 21.2.9
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 20.0.0-next.0, < 20.3.19
Обновитесь до 20.3.19
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 19.0.0-next.0, < 19.2.21
Обновитесь до 19.2.21
@angular/platform-server npm
- Затронутые диапазоны версий
- SEMVER: ≤ 18.2.14
Нет опубликованного исправления
angular.js Ubuntu:Pro:16.04:LTS
- Версии
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:Pro:18.04:LTS
- Версии
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:Pro:20.04:LTS
- Версии
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:22.04:LTS
- Версии
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:24.04:LTS
- Версии
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:25.10
- Версии
- 1.8.3-1
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:26.10
- Версии
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
angular.js Ubuntu:26.04:LTS
- Версии
- 1.8.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления