CVE-2026-41427
CVE-2026-41427 · Better Auth OAuth 2.1 Provider: Unprivileged users can register OAuth clients
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Better Auth is an authentication and authorization library for TypeScript. Prior to 1.6.5, the clientPrivileges option documents a create action, but the OAuth client creation endpoints did not invoke the hook before persisting new clients. Deployments that configured clientPrivileges to restrict client registration were not actually restricted — any authenticated user could reach the create endpoints and register an OAuth client with attacker-chosen redirect URIs and metadata. This vulnerability is fixed in 1.6.5.
CVSS 7.1 · Высокий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
better-auth
- Версии
- >= 1.4.8-beta.7, < 1.6.5: Затронуто
- >= 1.7.0-beta.0, <= 1.7.0-beta.1: Затронуто
Нет опубликованного исправления
oauth-provider
- Версии
- >= 1.4.8-beta.7, < 1.6.5: Затронуто
- >= 1.7.0-beta.0, <= 1.7.0-beta.1: Затронуто
Нет опубликованного исправления
@better-auth/oauth-provider npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.4.8-beta.7, < 1.6.5
Обновитесь до 1.6.5
@better-auth/oauth-provider npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.7.0-beta.0, ≤ 1.7.0-beta.1
Нет опубликованного исправления