CVE-2026-41674
CVE-2026-41674 · xmldom: XML injection through unvalidated DocumentType serialization
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In @xmldom/xmldom prior to versions 0.9.10 and 0.8.13 and xmldom version 0.6.0 and prior, the package serializes DocumentType node fields (internalSubset, publicId, systemId) verbatim without any escaping or validation. When these fields are set programmatically to attacker-controlled strings, XMLSerializer.serializeToString can produce output where the DOCTYPE declaration is terminated early and arbitrary markup appears outside it. This issue has been patched in versions @xmldom/xmldom versions 0.9.10 and 0.8.13.
CVSS 8.7 · Высокий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
xmldom
- Версии
- xmldom <= 0.6.0: Затронуто
- @xmldom/xmldom >= 0.9.0, < 0.9.10: Затронуто
- @xmldom/xmldom < 0.8.13: Затронуто
Нет опубликованного исправления
node-xmldom Debian:12
- Версии
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-xmldom Debian:13
- Версии
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-xmldom Debian:14
- Версии
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.9.10-1
Обновитесь до 0.9.10-1
@xmldom/xmldom npm
- Затронутые диапазоны версий
- SEMVER: < 0.8.13
Обновитесь до 0.8.13
@xmldom/xmldom npm
- Затронутые диапазоны версий
- SEMVER: ≥ 0.9.0, < 0.9.10
Обновитесь до 0.9.10
xmldom npm
- Затронутые диапазоны версий
- SEMVER: ≤ 0.6.0
Нет опубликованного исправления
node-xmldom Ubuntu:20.04:LTS
- Версии
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-xmldom Ubuntu:22.04:LTS
- Версии
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-xmldom Ubuntu:24.04:LTS
- Версии
- 0.8.6-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-xmldom Ubuntu:25.10
- Версии
- 0.9.6-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-xmldom Ubuntu:26.10
- Версии
- 0.9.8-2
- 0.9.10-2
- 0.9.11-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-xmldom Ubuntu:26.04:LTS
- Версии
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/xmldom/xmldom/security/advisories/GHSA-f6ww-3ggp-fr8h
- https://github.com/xmldom/xmldom/commit/372008f9ae0e20fd69f761c7b79e202598267314
- https://github.com/xmldom/xmldom/releases/tag/0.8.13
- https://github.com/xmldom/xmldom/releases/tag/0.9.10
- https://access.redhat.com/security/cve/CVE-2026-41674
- https://bugzilla.redhat.com/show_bug.cgi?id=2467620
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41674.json
- https://access.redhat.com/errata/RHSA-2026:21338
- https://access.redhat.com/errata/RHSA-2026:26234
- https://access.redhat.com/errata/RHSA-2026:21703
- https://access.redhat.com/errata/RHSA-2026:20034
- https://nvd.nist.gov/vuln/detail/CVE-2026-41674