p PatchFirst

CVE-2026-41989

CVE-2026-41989

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

CVSS 6.7 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • libgcrypt

    Версии
    • ≥ 1.8.8, < 1.10.4: Затронуто (semver)
    • ≥ 1.11.0, < 1.11.3: Затронуто (semver)
    • ≥ 1.12.0, < 1.12.2: Затронуто (semver)

    Обновитесь до 1.10.4; Обновитесь до 1.11.3; Обновитесь до 1.12.2

  • libgcrypt20 Debian:12

    Версии
    • 1.10.1-3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.10.1-3+deb12u1

    Обновитесь до 1.10.1-3+deb12u1

  • libgcrypt20 Debian:13

    Версии
    • 1.11.0-7
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.11.0-7+deb13u1

    Обновитесь до 1.11.0-7+deb13u1

  • libgcrypt20 Debian:14

    Версии
    • 1.11.0+git20250114-1
    • 1.11.0-7
    • 1.11.1-1
    • 1.11.2-1
    • 1.11.2-2
    • 1.11.2-3
    • 1.12.0-1
    • 1.12.0-2
    • 1.12.1-1
    • 1.12.1-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.12.2-1

    Обновитесь до 1.12.2-1

  • libgcrypt20 Ubuntu:Pro:16.04:LTS

    Версии
    • 1.6.3-2ubuntu1
    • 1.6.4-3
    • 1.6.4-4
    • 1.6.4-5
    • 1.6.5-2
    • 1.6.5-2ubuntu0.2
    • 1.6.5-2ubuntu0.3
    • 1.6.5-2ubuntu0.4
    • 1.6.5-2ubuntu0.5
    • 1.6.5-2ubuntu0.6
    • 1.6.5-2ubuntu0.6+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:18.04:LTS

    Версии
    • 1.7.8-2ubuntu1
    • 1.7.9-1
    • 1.8.1-4
    • 1.8.1-4ubuntu1
    • 1.8.1-4ubuntu1.1
    • 1.8.1-4ubuntu1.2
    • 1.8.1-4ubuntu1.3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS

    Версии
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    • 1.8.1-4ubuntu1.fips.3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS

    Версии
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:20.04:LTS

    Версии
    • 1.8.4-5ubuntu2
    • 1.8.5-3ubuntu1
    • 1.8.5-5ubuntu1
    • 1.8.5-5ubuntu1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS

    Версии
    • 1.8.5-5ubuntu1.fips.1.1
    • 1.8.5-5ubuntu1.fips.1.4
    • 1.8.5-5ubuntu1.fips.1.5
    • 1.8.5-5ubuntu1.fips.1.7
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS

    Версии
    • 1.8.5-5ubuntu1.fips.1.1
    • 1.8.5-5ubuntu1.fips.1.4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:22.04:LTS

    Версии
    • 1.8.7-5ubuntu2
    • 1.9.4-3ubuntu2
    • 1.9.4-3ubuntu3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.9.4-3ubuntu3.2

    Обновитесь до 1.9.4-3ubuntu3.2

  • libgcrypt20 Ubuntu:Pro:FIPS-preview:22.04:LTS

    Версии
    • 1.9.4-3ubuntu3+Fips1.1
    • 1.9.4-3ubuntu3+Fips1.2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:22.04:LTS

    Версии
    • 1.9.4-3ubuntu3+Fips1.1
    • 1.9.4-3ubuntu3+Fips1.2
    • 1.9.4-3ubuntu3+Fips1.3
    • 1.9.4-3ubuntu3+Fips1.4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.9.4-3ubuntu3.2+Fips1

    Обновитесь до 1.9.4-3ubuntu3.2+Fips1

  • libgcrypt20 Ubuntu:24.04:LTS

    Версии
    • 1.10.2-3ubuntu1
    • 1.10.3-2
    • 1.10.3-2build1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.10.3-2ubuntu0.1

    Обновитесь до 1.10.3-2ubuntu0.1

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:24.04:LTS

    Версии
    • 1.10.3-2ubuntu0.1~Fips1~rc6
    • 1.10.3-2ubuntu0.1~Fips1~rc7
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.12.0-2ubuntu0.1~Fips1~rc11

    Обновитесь до 1.12.0-2ubuntu0.1~Fips1~rc11

  • libgcrypt20 Ubuntu:25.10

    Версии
    • 1.11.0-6ubuntu1
    • 1.11.0-7
    • 1.11.0-7build1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.11.0-7ubuntu0.1

    Обновитесь до 1.11.0-7ubuntu0.1

  • libgcrypt20 Ubuntu:26.04:LTS

    Версии
    • 1.11.0-7build1
    • 1.11.2-2
    • 1.11.2-3
    • 1.12.0-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.12.0-2ubuntu0.1

    Обновитесь до 1.12.0-2ubuntu0.1

Первоисточники

Проверьте свой сервер →