p PatchFirst

CVE-2026-42089

CVE-2026-42089 · yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

CVSS 8.6 · Высокий · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • environment

    Версии
    • >= 2.9.0, < 6.0.1: Затронуто

    Нет опубликованного исправления

  • yeoman-environment npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.9.0, < 6.0.1

    Обновитесь до 6.0.1

Первоисточники

Проверьте свой сервер →