p PatchFirst

CVE-2026-42311

CVE-2026-42311 · Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

CVSS 8.6 · Высокий · EPSS 0,1% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • pillow

    Версии
    • >= 10.3.0, < 12.2.0: Затронуто

    Нет опубликованного исправления

  • pillow Debian:13

    Версии
    • 11.1.0-5
    • 11.1.0-5+deb13u1
    • 11.1.0-5+deb13u2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 11.1.0-5+deb13u3

    Обновитесь до 11.1.0-5+deb13u3

  • pillow Debian:14

    Версии
    • 11.1.0-5
    • 11.2.1-1
    • 11.3.0-1
    • 12.0.0-1
    • 12.1.0-1
    • 12.1.1-1
    • 12.1.1-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 12.2.0-1

    Обновитесь до 12.2.0-1

  • pillow PyPI

    Версии
    • 10.3.0
    • 10.4.0
    • 11.0.0
    • 11.1.0
    • 11.2.1
    • 11.3.0
    • 12.0.0
    • 12.1.0
    • 12.1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 10.3.0, < 12.2.0

    Обновитесь до 12.2.0

  • pillow-python2 Ubuntu:Pro:20.04:LTS

    Версии
    • 6.2.1-3~build1
    • 6.2.1-3
    • 6.2.1-3ubuntu0.1~esm1
    • 6.2.1-3ubuntu0.1~esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pillow Ubuntu:25.10

    Версии
    • 11.1.0-5build1
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu1.1
    • 11.3.0-1ubuntu1.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 11.3.0-1ubuntu1.3

    Обновитесь до 11.3.0-1ubuntu1.3

  • pillow Ubuntu:26.04:LTS

    Версии
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu2
    • 12.0.0-1ubuntu1
    • 12.1.1-1ubuntu1
    • 12.1.1-2ubuntu1
    • 12.1.1-2ubuntu1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 12.1.1-2ubuntu1.2

    Обновитесь до 12.1.1-2ubuntu1.2

Первоисточники

Проверьте свой сервер →