p PatchFirst

CVE-2026-42349

CVE-2026-42349 · Clerk: Authorization bypass when combining organization, billing, or reverification checks

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.

Clerk JavaScript is the official JavaScript repository for Clerk authentication. has(), auth.protect(), and related authorization predicates in @clerk/shared, @clerk/nextjs, @clerk/backend, and other framework SDKs can return true for certain combined authorization checks when the result should be false, allowing a gated action to proceed for a user who does not satisfy the full set of requested conditions. This call shape can be bypassed if certain conditions are met: a has() or auth.protect() call that combines a reverification check with any of role, permission, feature, or plan, or that combines a billing check (feature or plan) with a role or permission check. This vulnerability is fixed in @clerk/clerk-js 5.125.10 and 6.7.5.

CVSS 7.6 · Высокий · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • javascript

    Версии
    • >= 5.22.0, < 5.125.10: Затронуто
    • >= 6.0.0, < 6.7.5: Затронуто

    Нет опубликованного исправления

  • shared

    Версии
    • >= 3.0.0, <= 3.47.4: Затронуто
    • >= 4.0.0, <= 4.8.2: Затронуто

    Нет опубликованного исправления

  • backend

    Версии
    • >= 2.0.0, <= 2.33.2: Затронуто
    • >= 3.0.0, <= 3.2.13: Затронуто

    Нет опубликованного исправления

  • nextjs

    Версии
    • >= 6.0.0, <= 6.39.2: Затронуто
    • >= 7.0.0, <= 7.2.3: Затронуто

    Нет опубликованного исправления

  • clerk-react

    Версии
    • >= 5.9.0, <= 5.61.5: Затронуто

    Нет опубликованного исправления

  • react

    Версии
    • >= 6.0.0, <= 6.4.2: Затронуто

    Нет опубликованного исправления

  • vue

    Версии
    • >= 1.0.0, <= 1.17.20: Затронуто
    • >= 2.0.0, <= 2.0.15: Затронуто

    Нет опубликованного исправления

  • astro

    Версии
    • >= 2.0.0, <= 2.17.10: Затронуто
    • >= 3.0.0, <= 3.0.17: Затронуто

    Нет опубликованного исправления

  • nuxt

    Версии
    • >= 1.0.0, <= 1.13.28: Затронуто
    • >= 2.0.0, <= 2.2.4: Затронуто

    Нет опубликованного исправления

  • clerk-expo

    Версии
    • >= 2.2.11, <= 2.19.35: Затронуто

    Нет опубликованного исправления

  • expo

    Версии
    • >= 3.0.0, <= 3.2.1: Затронуто

    Нет опубликованного исправления

  • react-router

    Версии
    • >= 0.0.1, <= 2.4.12: Затронуто
    • >= 3.0.0, <= 3.1.3: Затронуто

    Нет опубликованного исправления

  • tanstack-react-start

    Версии
    • >= 0.0.1, <= 0.29.10: Затронуто
    • >= 1.0.0, <= 1.1.3: Затронуто

    Нет опубликованного исправления

  • chrome-extension

    Версии
    • >= 1.3.5, <= 2.9.14: Затронуто
    • >= 3.0.0, <= 3.1.14: Затронуто

    Нет опубликованного исправления

  • fastify

    Версии
    • >= 1.0.42, <= 2.6.30: Затронуто
    • >= 3.0.0, <= 3.1.15: Затронуто

    Нет опубликованного исправления

  • express

    Версии
    • >= 0.1.0, <= 1.7.78: Затронуто
    • >= 2.0.0, <= 2.1.5: Затронуто

    Нет опубликованного исправления

  • hono

    Версии
    • >= 0.0.2, <= 0.1.15: Затронуто

    Нет опубликованного исправления

  • @clerk/shared npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.0, < 3.47.5

    Обновитесь до 3.47.5

  • @clerk/shared npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.8.3

    Обновитесь до 4.8.3

  • @clerk/backend npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0, < 2.33.3

    Обновитесь до 2.33.3

  • @clerk/backend npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.0, < 3.2.14

    Обновитесь до 3.2.14

  • @clerk/nextjs npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 6.0.0, < 6.39.3

    Обновитесь до 6.39.3

  • @clerk/nextjs npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.0.0, < 7.2.4

    Обновитесь до 7.2.4

  • @clerk/clerk-js npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 5.22.0, < 5.125.10

    Обновитесь до 5.125.10

Первоисточники

Проверьте свой сервер →