p PatchFirst

CVE-2026-43944

CVE-2026-43944 · electerm: dangerous code can be run through links or command line

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

CVSS 9.4 · Критический · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • electerm

    Версии
    • >= 3.0.6, < 3.8.15: Затронуто

    Нет опубликованного исправления

  • electerm npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.6, < 3.8.8

    Обновитесь до 3.8.8

Первоисточники

Проверьте свой сервер →