p PatchFirst

CVE-2026-44574

CVE-2026-44574 · Next.js: Middleware / Proxy bypass through dynamic route parameter injection

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.

CVSS 8.1 · Высокий · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next.js

    Версии
    • >= 15.4.0, < 15.5.16: Затронуто
    • >= 16.0.0, < 16.2.5: Затронуто

    Нет опубликованного исправления

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 15.4.0, < 15.5.16

    Обновитесь до 15.5.16

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 16.0.0, < 16.2.5

    Обновитесь до 16.2.5

Первоисточники

Проверьте свой сервер →