p PatchFirst

CVE-2026-44578

CVE-2026-44578 · Next.js: Server-side request forgery in applications using WebSocket upgrades

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

CVSS 8.6 · Высокий · EPSS 35,5% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next.js

    Версии
    • >= 16.0.0, < 16.2.5: Затронуто
    • >= 13.4.13, < 15.5.16: Затронуто

    Нет опубликованного исправления

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 13.4.13, < 15.5.16

    Обновитесь до 15.5.16

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 16.0.0, < 16.2.5

    Обновитесь до 16.2.5

Первоисточники

Проверьте свой сервер →