p PatchFirst

CVE-2026-44580

CVE-2026-44580 · Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

CVSS 6.1 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next.js

    Версии
    • >= 13.0.0, < 15.5.16: Затронуто
    • >= 16.0.0, < 16.2.5: Затронуто

    Нет опубликованного исправления

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 13.0.0, < 15.5.16

    Обновитесь до 15.5.16

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 16.0.0, < 16.2.5

    Обновитесь до 16.2.5

Первоисточники

Проверьте свой сервер →