p PatchFirst

CVE-2026-45809

CVE-2026-45809 · OpenSIPS: Denial of Service in watcherinfo XML generation from oversized watcher URI

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the watcherinfo generation functionality. An attacker can create an oversized watcher entry by sending a SUBSCRIBE Event: presence request with a long From URI, and then trigger presence.winfo watcherinfo XML generation for the same presentity. OpenSIPS copies the stored watcher URI into a fixed-size stack buffer, overflowing it and crashing the process. A remote attacker can crash an OpenSIPS worker in deployments that expose handle_subscribe() and allow watcherinfo (presence.winfo) generation. The issue is configuration-dependent because the presence and presence_xml modules must be loaded and SUBSCRIBE routing must be reachable. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

CVSS 8.7 · Высокий · EPSS 0,6%

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • opensips

    Версии
    • >= 3.4.0, < 3.6.6: Затронуто
    • >= 4.0.0-beta, < 4.0.0-rc1: Затронуто

    Нет опубликованного исправления

  • opensips Ubuntu:18.04:LTS

    Версии
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →