CVE-2026-46421
CVE-2026-46421 · Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/sqlite@2.2.2`, `@cap-js/postgres@2.2.2`, and `@cap-js/db-service@2.10.1` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.
CVSS 9.3 · Критический · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
@cap-js/sqlite
- Версии
- = 2.2.2: Затронуто
Нет опубликованного исправления
@cap-js/postgres
- Версии
- = 2.2.2: Затронуто
Нет опубликованного исправления
@cap-js/db-service
- Версии
- = 2.10.1: Затронуто
Нет опубликованного исправления
@cap-js/sqlite npm
- Версии
- 2.2.2
- Затронутые диапазоны версий
- SEMVER: ≥ 2.2.2, < 2.3.0
Обновитесь до 2.3.0
@cap-js/postgres npm
- Версии
- 2.2.2
- Затронутые диапазоны версий
- SEMVER: ≥ 2.2.2, < 2.3.0
Обновитесь до 2.3.0
@cap-js/db-service npm
- Версии
- 2.10.1
- Затронутые диапазоны версий
- SEMVER: ≥ 2.10.1, < 2.11.0
Обновитесь до 2.11.0