CVE-2026-47138
CVE-2026-47138 · Parse Server: Pre-authentication denial of service via client version header regex backtracking
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.77 and 9.9.1-alpha.1, an unauthenticated attacker who knows a publicly-known Parse Application ID can submit a single HTTP request whose client SDK version field contains adversarial input that triggers polynomial backtracking in a request-header parser. The parsing runs before session authentication and before rate limiting on every /parse/* request, so the request consumes seconds to minutes of synchronous CPU on a Node.js worker before any access control evaluates it. A small number of concurrent requests can saturate a worker; a single large request via the body-field variant can pin a worker for minutes. Production deployments running the default configuration are affected. This issue has been patched in versions 8.6.77 and 9.9.1-alpha.1.
CVSS 8.7 · Высокий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
parse-server
- Версии
- < 8.6.77: Затронуто
- >= 9.0.0, < 9.9.1-alpha.1: Затронуто
Нет опубликованного исправления
parse-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 9.0.0, < 9.9.1-alpha.1
Обновитесь до 9.9.1-alpha.1
parse-server npm
- Затронутые диапазоны версий
- SEMVER: < 8.6.77
Обновитесь до 8.6.77