p PatchFirst

CVE-2026-48068

CVE-2026-48068 · @grpc/grps-js: A malformed request can cause a server crash

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

CVSS 7.5 · Высокий · EPSS 0,9% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • grpc-node

    Версии
    • < 1.9.16: Затронуто
    • >= 1.11.0, < 1.11.4: Затронуто
    • >= 1.12.0, < 1.12.7: Затронуто
    • >= 1.13.0, < 1.13.5: Затронуто
    • >= 1.14.0, < 1.14.4: Затронуто
    • >= 1.10.0, < 1.10.12: Затронуто

    Нет опубликованного исправления

  • @grpc/grpc-js npm

    Затронутые диапазоны версий
    • SEMVER: < 1.9.16

    Обновитесь до 1.9.16

  • @grpc/grpc-js npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.10.0, < 1.10.12

    Обновитесь до 1.10.12

  • @grpc/grpc-js npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.11.0, < 1.11.4

    Обновитесь до 1.11.4

  • @grpc/grpc-js npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.12.0, < 1.12.7

    Обновитесь до 1.12.7

  • @grpc/grpc-js npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.13.0, < 1.13.5

    Обновитесь до 1.13.5

  • @grpc/grpc-js npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.14.0, < 1.14.4

    Обновитесь до 1.14.4

Первоисточники

Проверьте свой сервер →