CVE-2026-48207
CVE-2026-48207 · Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes. This issue affects Apache Fory: from before 1.0.0. Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
CVSS 9.8 · Критический · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
apache fory
- Версии
- ≥ 0.13.0, < 1.0.0: Затронуто (semver)
Обновитесь до 1.0.0
pyfory PyPI
- Версии
- 0.13.0
- 0.13.1
- 0.13.2
- 0.14.0
- 0.14.1
- 0.15.0
- 0.16.0
- 0.17.0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 0.13.0, < 1.0.0
Обновитесь до 1.0.0