p PatchFirst

CVE-2026-48717

CVE-2026-48717 · OpenAM OAuth Authorization Bypass via PKCE Challenge

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.

CVSS 9.1 · Критический · EPSS 0,5%

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • openam

    Версии
    • < 16.1.1: Затронуто

    Нет опубликованного исправления

  • openam Ubuntu:16.04:LTS

    Версии
    • 1.4.0-1build6
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →