p PatchFirst

CVE-2026-48990

CVE-2026-48990 · joserfc: b64=false RFC7797 JWS payloads bypass JWSRegistry payload-size limits during deserialization

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards. In versions 1.3.4 through 1.6.5, joserfc accepts oversized RFC7797 b64=false JWS payloads without applying JWSRegistry.max_payload_length, which can lead to resource exhaustion. The normal JWS compact and flattened JSON paths reject payloads above the configured payload-size limit with ExceededSizeError. The RFC7797 unencoded payload paths do not make the same check. A valid b64=false compact or flattened JSON JWS can therefore deserialize successfully with a payload larger than JWSRegistry.max_payload_length. Applications that accept lower-trust JWS values and rely on joserfc to reject oversized token content during verification have a moderate availability risk. This issue has been fixed in version 1.6.7.

CVSS 5.3 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • joserfc

    Версии
    • < 1.6.7: Затронуто

    Нет опубликованного исправления

  • joserfc Debian:13

    Версии
    • 1.1.0-1
    • 1.2.0-1
    • 1.2.2-1
    • 1.3.1-1
    • 1.3.2-1
    • 1.3.4-1
    • 1.4.0-1
    • 1.4.1-1
    • 1.4.3-1
    • 1.5.0-1
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.2-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    • 1.6.8-1
    • 1.7.0-1
    • 1.7.1-1
    • 1.7.2-1
    • 1.7.3-1
    • 1.7.4-1
    • 1.7.5-1
    • 1.7.7-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • joserfc Debian:14

    Версии
    • 1.1.0-1
    • 1.2.0-1
    • 1.2.2-1
    • 1.3.1-1
    • 1.3.2-1
    • 1.3.4-1
    • 1.4.0-1
    • 1.4.1-1
    • 1.4.3-1
    • 1.5.0-1
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.2-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.8-1

    Обновитесь до 1.6.8-1

  • joserfc PyPI

    Версии
    • 1.3.4
    • 1.3.5
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.5.0
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.3.4, < 1.6.7

    Обновитесь до 1.6.7

  • joserfc Ubuntu:25.10

    Версии
    • 1.0.4-1
    • 1.1.0-1
    • 1.2.0-1
    • 1.2.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • joserfc Ubuntu:26.04:LTS

    Версии
    • 1.2.2-1
    • 1.4.0-1
    • 1.4.1-1
    • 1.4.3-1
    • 1.5.0-1
    • 1.6.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →