p PatchFirst

CVE-2026-49476

CVE-2026-49476 · Soup Sieve: Memory Exhaustion via Large Comma-Separated Selector Lists in soupsieve

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve allocates unbounded memory when compiling large comma-separated selector lists, allowing an attacker who can supply a crafted selector string to soupsieve.compile() or Beautiful Soup .select() / .select_one() to allocate hundreds of megabytes of heap memory from a relatively small input and cause denial of service. This issue is fixed in version 2.8.4.

CVSS 7.5 · Высокий · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • soupsieve

    Версии
    • < 2.8.4: Затронуто

    Нет опубликованного исправления

  • soupsieve Debian:12

    Версии
    • 2.3.2-1
    • 2.4-1
    • 2.4.1-1
    • 2.4.1-2
    • 2.5-1
    • 2.6-1
    • 2.7-1
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    • 2.8.4-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • soupsieve Debian:13

    Версии
    • 2.7-1
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    • 2.8.4-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • soupsieve Debian:14

    Версии
    • 2.7-1
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.8.4-1

    Обновитесь до 2.8.4-1

  • soupsieve PyPI

    Версии
    • 0.4
    • 0.5
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.6
    • 1.0
    • 1.0.1
    • 1.0.2
    • 1.0b1
    • 1.0b2
    • 1.1
    • 1.2
    • 1.2.1
    • 1.3
    • 1.3.1
    • 1.4
    • 1.5
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.7
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8
    • 1.9
    • 1.9.1
    • 1.9.2
    • 1.9.3
    • 1.9.4
    • 1.9.5
    • 1.9.6
    • 2.0
    • 2.0.1
    • 2.1
    • 2.2
    • 2.2.1
    • 2.3
    • 2.3.1
    • 2.3.2
    • 2.3.2.post1
    • 2.4
    • 2.4.1
    • 2.5
    • 2.6
    • 2.7
    • 2.8
    • 2.8.1
    • 2.8.2
    • 2.8.3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.8.4

    Обновитесь до 2.8.4

  • soupsieve Ubuntu:20.04:LTS

    Версии
    • 1.9.2+dfsg-2ubuntu1
    • 1.9.4+dfsg-1
    • 1.9.5+dfsg-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • soupsieve Ubuntu:22.04:LTS

    Версии
    • 2.2.1-2
    • 2.3-1
    • 2.3.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • soupsieve Ubuntu:24.04:LTS

    Версии
    • 2.4.1-2
    • 2.5-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • soupsieve Ubuntu:26.10

    Версии
    • 2.8.3-1
    • 2.8.4-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • soupsieve Ubuntu:26.04:LTS

    Версии
    • 2.7-2
    • 2.8.1-1
    • 2.8.3-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →