CVE-2026-49836
CVE-2026-49836 · psd-tools: arbitrary file write via smart-object filename
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.17.1, `SmartObject.save()` writes an embedded smart object to a path taken verbatim from the PSD file. Because that name is attacker-controlled and unsanitised, a tool that extracts embedded objects from an untrusted `.psd` can be made to write attacker-chosen bytes to an attacker-chosen path (absolute or `../`-traversing), outside its intended output directory. A secondary issue in `SmartObject.open()` for external-kind smart objects allows the attacker-controlled `fullPath` descriptor to be used as an arbitrary file read path, enabling exfiltration of the read content to the controlled write destination. Both issues are fixed in v1.17.1.
CVSS 4.6 · Средний · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
psd-tools
- Версии
- < 1.17.1: Затронуто
Нет опубликованного исправления
psd-tools Debian:12
- Версии
- 1.10.7+dfsg.1-1
- 1.10.9+dfsg.1-1
- 1.12.0+dfsg.1-1
- 1.12.1+dfsg.1-1
- 1.14.2+dfsg.1-1
- 1.14.3+dfsg.1-1
- 1.15.0+dfsg.1-1
- 1.16.0+dfsg.1-1
- 1.17.0+dfsg.1-1
- 1.17.4+dfsg.1-1
- 1.9.24+dfsg.1-1
- 1.9.28+dfsg.1-1
- 1.9.30+dfsg.1-1
- 1.9.31+dfsg.1-1
- 1.9.32+dfsg.1-1
- 1.9.34+dfsg.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
psd-tools Debian:13
- Версии
- 1.10.7+dfsg.1-1
- 1.10.7+dfsg.1-1+deb13u1
- 1.10.9+dfsg.1-1
- 1.12.0+dfsg.1-1
- 1.12.1+dfsg.1-1
- 1.14.2+dfsg.1-1
- 1.14.3+dfsg.1-1
- 1.15.0+dfsg.1-1
- 1.16.0+dfsg.1-1
- 1.17.0+dfsg.1-1
- 1.17.4+dfsg.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
psd-tools Debian:14
- Версии
- 1.10.7+dfsg.1-1
- 1.10.9+dfsg.1-1
- 1.12.0+dfsg.1-1
- 1.12.1+dfsg.1-1
- 1.14.2+dfsg.1-1
- 1.14.3+dfsg.1-1
- 1.15.0+dfsg.1-1
- 1.16.0+dfsg.1-1
- 1.17.0+dfsg.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.17.4+dfsg.1-1
Обновитесь до 1.17.4+dfsg.1-1
psd-tools PyPI
- Версии
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.10
- 0.2
- 0.5
- 0.6
- 0.7
- 0.7.1
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.9
- 0.9.1
- 1.0
- 1.1
- 1.10.0
- 1.10.1
- 1.10.10
- 1.10.11
- 1.10.12
- 1.10.13
- 1.10.2
- 1.10.3
- 1.10.4
- 1.10.5
- 1.10.6
- 1.10.7
- 1.10.8
- 1.10.9
- 1.11.0
- 1.11.1
- 1.12.0
- 1.12.1
- 1.12.2
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.14.2
- 1.14.3
- 1.15.0.post1
- 1.16.0
- 1.17.0
- 1.2
- 1.3
- 1.4
- 1.8.10
- 1.8.11
- 1.8.12
- 1.8.13
- 1.8.14
- 1.8.15
- 1.8.16
- 1.8.17
- 1.8.18
- 1.8.19
- 1.8.20
- 1.8.21
- 1.8.22
- 1.8.23
- 1.8.24
- 1.8.25
- 1.8.26
- 1.8.27
- 1.8.28
- 1.8.29
- 1.8.30
- 1.8.31
- 1.8.32
- 1.8.33
- 1.8.34
- 1.8.35
- 1.8.36
- 1.8.37
- 1.8.38
- 1.8.8
- 1.8.9
- 1.9.0
- 1.9.1
- 1.9.10
- 1.9.11
- 1.9.12
- 1.9.13
- 1.9.14
- 1.9.15
- 1.9.16
- 1.9.17
- 1.9.18
- 1.9.19
- 1.9.2
- 1.9.20
- 1.9.21
- 1.9.22
- 1.9.23
- 1.9.24
- 1.9.26
- 1.9.27
- 1.9.28
- 1.9.29
- 1.9.3
- 1.9.30
- 1.9.31
- 1.9.32
- 1.9.33
- 1.9.34
- 1.9.4
- 1.9.5
- 1.9.6
- 1.9.7
- 1.9.8
- 1.9.9
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.17.1
Обновитесь до 1.17.1
psd-tools Ubuntu:24.04:LTS
- Версии
- 1.9.28+dfsg.1-1
- 1.9.28+dfsg.1-1build1
- 1.9.30+dfsg.1-1
- 1.9.30+dfsg.1-1build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
psd-tools Ubuntu:26.04:LTS
- Версии
- 1.10.7+dfsg.1-1
- 1.10.7+dfsg.1-1build1
- 1.10.9+dfsg.1-1
- 1.12.0+dfsg.1-1
- 1.12.1+dfsg.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/psd-tools/psd-tools/security/advisories/GHSA-2rmg-vrx8-9j2f
- https://github.com/psd-tools/psd-tools/pull/657
- https://github.com/pypa/advisory-database/tree/main/vulns/psd-tools/PYSEC-2026-2969.yaml
- http://github.com/psd-tools/psd-tools/releases/tag/v1.17.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-49836