p PatchFirst

CVE-2026-5079

CVE-2026-5079 · multer vulnerable to Denial of Service via deeply nested field names

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.

CVSS 7.5 · Высокий · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • multer

    Версии
    • ≥ 1.0.0, < 2.2.0: Затронуто (semver)
    • 2.2.0: Не затронуто (semver)
    • ≥ 3.0.0-alpha.1, < 3.0.0-alpha.2: Затронуто (semver)
    • 3.0.0-alpha.2: Не затронуто (semver)

    Обновитесь до 2.2.0; Обновитесь до 3.0.0-alpha.2

  • multer npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.0.0, < 2.2.0

    Обновитесь до 2.2.0

  • multer npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.0-alpha.1, < 3.0.0-alpha.2

    Обновитесь до 3.0.0-alpha.2

Первоисточники

Проверьте свой сервер →