p PatchFirst

CVE-2026-52725

CVE-2026-52725 · Angular Template and Dynamic Component Namespace Bypass leading to Cross-Site Scripting (XSS)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/core package allows bypassing script-execution restrictions during dynamic component creation. Specifically, the dynamic component instantiation mechanism (createComponent) failed to reject mounting components directly onto a <script> or namespaced script element (such as <svg:script>). This enabled the initialization of custom components on a tag that executes scripts, allowing attackers to hijack or inject script-executing hosts. This flaw enables an attacker who can control the host element or selector parameter passed to createComponent to initialize or mount an Angular component directly onto a <script> tag, leading to execution of untrusted code or client-side Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

CVSS 5.3 · Средний · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • angular

    Версии
    • >= 22.0.0-next.0 < 22.0.0-rc.2: Затронуто
    • >= 21.0.0-next.0 < 21.2.15: Затронуто
    • >= 20.0.0-next.0 < 20.3.22: Затронуто
    • >= 19.0.0-next.0 < 19.2.22: Затронуто
    • <= 18.2.14: Затронуто

    Нет опубликованного исправления

  • angular.js Debian:12

    Версии
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Debian:13

    Версии
    • 1.8.3-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.15

    Обновитесь до 21.2.15

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2

    Обновитесь до 22.0.0-rc.2

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.23

    Обновитесь до 19.2.23

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: ≤ 18.2.14

    Нет опубликованного исправления

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.22

    Обновитесь до 20.3.22

  • angular.js Ubuntu:Pro:16.04:LTS

    Версии
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Ubuntu:Pro:18.04:LTS

    Версии
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Ubuntu:Pro:20.04:LTS

    Версии
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Ubuntu:22.04:LTS

    Версии
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Ubuntu:24.04:LTS

    Версии
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Ubuntu:25.10

    Версии
    • 1.8.3-1
    • 1.8.3-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Ubuntu:26.10

    Версии
    • 1.8.3-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • angular.js Ubuntu:26.04:LTS

    Версии
    • 1.8.3-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →