CVE-2026-54328
CVE-2026-54328 · Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.
CVSS 7.3 · Высокий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
pi
- Версии
- >= 0.74.0, < 0.78.1: Затронуто
Нет опубликованного исправления
@earendil-works/pi-coding-agent npm
- Затронутые диапазоны версий
- SEMVER: ≥ 0.74.0, < 0.78.1
Обновитесь до 0.78.1
@mariozechner/pi-coding-agent npm
- Затронутые диапазоны версий
- SEMVER: ≥ 0.50.0, ≤ 0.73.1
Нет опубликованного исправления
Первоисточники
- https://github.com/earendil-works/pi/security/advisories/GHSA-jfgx-wxx8-mp94
- https://github.com/earendil-works/pi/pull/5345
- https://github.com/earendil-works/pi/commit/a98e087e5d08ea2a536bf73dbb0aebb87c3ef72e
- https://github.com/earendil-works/pi/commit/ea3465a8e371a12d0167a06b60f93878e3a3df44
- https://github.com/earendil-works/pi/releases/tag/v0.78.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-54328