p PatchFirst

CVE-2026-55253

CVE-2026-55253 · LangChain MongoDB: NoSQL Operator Injection in MongoDBSaver.list() leading to cross-tenant data exposure

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

LangChain MongoDB provides integrations between MongoDB, Atlas, LangChain, and LangGraph. Prior to langgraph-checkpoint-mongodb 0.3.0 and langgraph-store-mongodb 0.4.0, MongoDBSaver.list(), MongoDBSaver.alist(), and MongoDBStore.search() incorporate filter dictionaries into MongoDB queries without recursively rejecting keys prefixed with $. An authenticated caller who controls a filter argument through HTTP query parameters, request body fields, or agent tool arguments can inject MongoDB Query Language operators such as $regex or $where. In a multi-tenant deployment that uses the filter to enforce per-user or per-tenant isolation, injected operators can bypass intended equality filtering and expose other tenants' checkpoint or store data. Filters constructed entirely from trusted server-side values have lower practical risk. This issue is fixed in langgraph-checkpoint-mongodb 0.3.0 and langgraph-store-mongodb 0.4.0.

CVSS 7.7 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • langchain-mongodb

    Версии
    • < 0.4.0: Затронуто

    Нет опубликованного исправления

  • langgraph-checkpoint-mongodb

    Версии
    • < 0.3.0: Затронуто

    Нет опубликованного исправления

  • langgraph-store-mongodb

    Версии
    • < 0.4.0: Затронуто

    Нет опубликованного исправления

  • langgraph-checkpoint-mongodb PyPI

    Версии
    • 0.1.0
    • 0.1.0a0
    • 0.1.0a1
    • 0.1.0a3
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.2.0
    • 0.2.1
    • 0.2.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.3.0

    Обновитесь до 0.3.0

  • langgraph-store-mongodb PyPI

    Версии
    • 0.0.1
    • 0.1.0
    • 0.1.1
    • 0.2.0
    • 0.3.0
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.4.0

    Обновитесь до 0.4.0

Первоисточники

Проверьте свой сервер →