p PatchFirst

CVE-2026-55854

CVE-2026-55854 · MariaDB Connector/Node.js: Cleartext Transmission of Sensitive Information and Insufficiently Protected Credentials in mariadb

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.4, 3.3.3, 3.4.6, and 3.5.3, MariaDB Connector/Node.js can disclose an account password when PAM dialog authentication is negotiated over an insecure transport. In lib/cmd/handshake/auth/pam-password-auth.js and lib/cmd/handshake/authentication.js, the SendPamAuthPacketFactory behavior for the server-side plugin dialog lacked the secure-transport gate applied to mysql_clear_password. With the default sslMode=DISABLE and restrictedAuth=null settings, a hostile or on-path server can send an Authentication Switch Request for dialog over plain TCP, causing the connector to return the account password in cleartext. Properly verified TLS and a local Unix socket prevent this path, while fingerprint-only server identity validation is not sufficient. This issue is fixed in versions 3.2.4, 3.3.3, 3.4.6, and 3.5.3.

CVSS 5.9 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node · database

Затронутые продукты и версии

  • mariadb-connector-nodejs

    Версии
    • < 3.2.4: Затронуто
    • >= 3.3.0, < 3.3.3: Затронуто
    • >= 3.4.0, < 3.4.6: Затронуто
    • >= 3.5.0, < 3.5.3: Затронуто

    Нет опубликованного исправления

  • mariadb npm

    Затронутые диапазоны версий
    • SEMVER: < 3.2.4

    Обновитесь до 3.2.4

  • mariadb npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.3.0, < 3.3.3

    Обновитесь до 3.3.3

  • mariadb npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.4.0, < 3.4.6

    Обновитесь до 3.4.6

  • mariadb npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.5.0, < 3.5.3

    Обновитесь до 3.5.3

Первоисточники

Проверьте свой сервер →