p PatchFirst

CVE-2026-56356

CVE-2026-56356 · n8n - Stored Cross-Site Scripting in Chat Trigger Node Custom CSS Field

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.

CVSS 5.1 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • n8n

    Версии
    • ≥ 0, < 1.123.27: Затронуто (semver)
    • 1.123.27: Не затронуто (semver)
    • ≥ 2.0.0-rc.0, < 2.13.3: Затронуто (semver)
    • 2.13.3: Не затронуто (semver)
    • ≥ 2.14.0, < 2.14.1: Затронуто (semver)
    • 2.14.1: Не затронуто (semver)

    Обновитесь до 1.123.27; Обновитесь до 2.13.3; Обновитесь до 2.14.1

  • n8n

    Версии
    • ≥ 0, < 2.14.1: Затронуто (semver)
    • 2.14.1: Не затронуто (semver)

    Обновитесь до 2.14.1

  • n8n

    Версии
    • ≥ 0, < 2.13.3: Затронуто (semver)
    • 2.13.3: Не затронуто (semver)

    Обновитесь до 2.13.3

  • n8n npm

    Затронутые диапазоны версий
    • SEMVER: < 1.123.27

    Обновитесь до 1.123.27

  • n8n npm

    Версии
    • 2.14.0
    Затронутые диапазоны версий
    • SEMVER: ≥ 2.14.0, < 2.14.1

    Обновитесь до 2.14.1

  • n8n npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0-rc.0, < 2.13.3

    Обновитесь до 2.13.3

Первоисточники

Проверьте свой сервер →