p PatchFirst

CVE-2026-57480

CVE-2026-57480 · Parse Server: Denial of service via exponential-time processing of deeply nested query operators

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.

CVSS 8.7 · Высокий · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • parse-server

    Версии
    • >= 9.0.0-alpha.1, < 9.9.1-alpha.12: Затронуто
    • < 8.6.82: Затронуто

    Нет опубликованного исправления

  • parse-server npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 9.0.0, < 9.9.1-alpha.12

    Обновитесь до 9.9.1-alpha.12

  • parse-server npm

    Затронутые диапазоны версий
    • SEMVER: < 8.6.82

    Обновитесь до 8.6.82

Первоисточники

Проверьте свой сервер →