CVE-2026-59884
CVE-2026-59884 · pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER decoder shared by the CER and DER codecs parses long-form tags by accumulating continuation octets without an upper bound on the tag ID size, allowing a crafted input to force construction of an arbitrarily large integer with CPU cost growing quadratically and to trigger unhandled ValueError exceptions in Python 3.11+ error formatting paths. Any application decoding untrusted BER, CER, or DER input is affected. This issue is fixed in version 0.6.4.
CVSS 7.5 · Высокий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
pyasn1
- Версии
- < 0.6.4: Затронуто
Нет опубликованного исправления
pyasn1 Debian:12
- Версии
- 0.4.8-3
- 0.4.8-3+deb12u1
- 0.4.8-3+deb12u2
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.4.8-3+deb12u3
Обновитесь до 0.4.8-3+deb12u3
pyasn1 Debian:13
- Версии
- 0.6.1-1
- 0.6.1-1+deb13u1
- 0.6.1-1+deb13u2
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.6.1-1+deb13u3
Обновитесь до 0.6.1-1+deb13u3
pyasn1 Debian:14
- Версии
- 0.6.1-1
- 0.6.2-1
- 0.6.2-1~bpo13+1
- 0.6.3-1
- 0.6.4-1~bpo13+1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.6.4-1
Обновитесь до 0.6.4-1
pyasn1 PyPI
- Версии
- 0.0.10a
- 0.0.11a
- 0.0.12a
- 0.0.13
- 0.0.13a
- 0.0.13b
- 0.0.6a
- 0.0.9a
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.1
- 0.2.2
- 0.2.3
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.4.5
- 0.4.6
- 0.4.7
- 0.4.8
- 0.5.0
- 0.5.1
- 0.6.0
- 0.6.1
- 0.6.2
- 0.6.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.6.4
Обновитесь до 0.6.4
pyasn1 Ubuntu:Pro:14.04:LTS
- Версии
- 0.1.4-0ubuntu1
- 0.1.7-1ubuntu1
- 0.1.7-1ubuntu2
- 0.1.7-1ubuntu2.1
- 0.1.7-1ubuntu2.1+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
pyasn1 Ubuntu:Pro:16.04:LTS
- Версии
- 0.1.8-2
- 0.1.9-1
- 0.1.9-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
pyasn1 Ubuntu:Pro:18.04:LTS
- Версии
- 0.1.9-2
- 0.4.2-3
- 0.4.2-3ubuntu0.18.04.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
pyasn1 Ubuntu:Pro:20.04:LTS
- Версии
- 0.4.2-3
- 0.4.2-3build1
- 0.4.2-3ubuntu0.20.04.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
pyasn1 Ubuntu:22.04:LTS
- Версии
- 0.4.8-1
- 0.4.8-1ubuntu0.1
- 0.4.8-1ubuntu0.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.4.8-1ubuntu0.3
Обновитесь до 0.4.8-1ubuntu0.3
pyasn1 Ubuntu:24.04:LTS
- Версии
- 0.4.8-4
- 0.4.8-4ubuntu0.1
- 0.4.8-4ubuntu0.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.4.8-4ubuntu0.3
Обновитесь до 0.4.8-4ubuntu0.3
pyasn1 Ubuntu:26.04:LTS
- Версии
- 0.6.1-1
- 0.6.1-1build1
- 0.6.2-1
- 0.6.3-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.6.3-1ubuntu0.1
Обновитесь до 0.6.3-1ubuntu0.1