CVE-2026-59965
CVE-2026-59965 · @jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.
CVSS 7.1 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
payload-plugins
- Версии
- < 0.8.0: Затронуто
Нет опубликованного исправления
payload-alt-text-plugin
- Версии
- < 0.8.0: Затронуто
Нет опубликованного исправления
@jhb.software/payload-alt-text-plugin npm
- Затронутые диапазоны версий
- SEMVER: < 0.8.0
Обновитесь до 0.8.0
Первоисточники
- https://github.com/jhb-software/payload-plugins/security/advisories/GHSA-4qpv-39hg-f7fx
- https://github.com/jhb-software/payload-plugins/pull/159
- https://github.com/jhb-software/payload-plugins/commit/e39634868ce13a414e2981e219befc58101654d3
- https://github.com/jhb-software/payload-plugins/releases/tag/alt-text@0.8.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-59965