p PatchFirst

CVE-2026-59973

CVE-2026-59973 · mcp-from-openapi: Bypass of OpenAPI external $ref SSRF fix in latest FrontMCP and mcp-from-openapi

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

FrontMCP is a TypeScript-first framework for the Model Context Protocol (MCP). From mcp-from-openapi 2.3.0 until 2.5.0 and from frontmcp and @frontmcp/adapters 1.2.1 until 1.5.0, libs/adapters/src/openapi/openapi.adapter.ts loadOpenAPISpec() forwards untrusted OpenAPI url and spec inputs and loadOptions.refResolution to OpenAPIToolGenerator.fromURL() and OpenAPIToolGenerator.fromJSON(). The external $ref guard checks parsed hostname strings without resolving addresses, pinning validated addresses, revalidating redirect targets, or normalizing IPv4-mapped IPv6. An authenticated user who can import or configure an OpenAPI specification in a hosted or multi-user deployment can use DNS-to-loopback resolution, redirect-to-loopback behavior, or IPv4-mapped IPv6 loopback forms to cause backend-origin requests to internal services. This can expose internal administrative APIs, metadata-like services, and other private network endpoints. The practical impact is lower when only a trusted local administrator can configure OpenAPI specs, and disabling external reference protocols prevents the external $ref request. This issue is fixed in mcp-from-openapi 2.5.0 and frontmcp and @frontmcp/adapters 1.5.0.

CVSS 8.5 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • frontmcp

    Версии
    • < 1.5.0: Затронуто

    Нет опубликованного исправления

  • mcp-from-openapi

    Версии
    • < 2.5.0: Затронуто

    Нет опубликованного исправления

  • adapters

    Версии
    • < 1.5.0: Затронуто

    Нет опубликованного исправления

  • mcp-from-openapi npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.3.0, < 2.5.0

    Обновитесь до 2.5.0

  • @frontmcp/adapters npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.2.1, < 1.5.0

    Обновитесь до 1.5.0

  • frontmcp npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.2.1, < 1.5.0

    Обновитесь до 1.5.0

Первоисточники

Проверьте свой сервер →