CVE-2026-62364
CVE-2026-62364 · wlc may disclose API tokens to project-configured URLs
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
wlc is a Weblate command-line client using Weblate's REST API. Prior to 2.0.1, automatically discovered configuration from .weblate, .weblate.ini, or weblate.ini can select the API URL while an unscoped API token is supplied through WLC_KEY or --key without a matching WLC_URL or --url. When wlc runs in an untrusted repository, pull request checkout, or directory with untrusted ancestor configuration, it can send the token to an attacker-controlled project-configured URL. URL-scoped keys in [keys] are not affected. This issue is fixed in version 2.0.1.
CVSS 2.3 · Низкий · EPSS 0,1% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
wlc
- Версии
- < 2.0.1: Затронуто
Нет опубликованного исправления
wlc Debian:12
- Версии
- 1.13-2
- 1.14-1
- 1.15-1
- 1.15-2
- 1.16.1-1
- 1.17.2-1
- 2.0.0-1
- 2.2.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wlc Debian:13
- Версии
- 1.15-1
- 1.15-2
- 1.16.1-1
- 1.17.2-1
- 2.0.0-1
- 2.2.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wlc Debian:14
- Версии
- 1.15-1
- 1.15-2
- 1.16.1-1
- 1.17.2-1
- 2.0.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.2.1-1
Обновитесь до 2.2.1-1
wlc PyPI
- Версии
- 0.0
- 0.1
- 0.10
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.7
- 0.8
- 0.9
- 1.0
- 1.1
- 1.10
- 1.11
- 1.12
- 1.13
- 1.14
- 1.15
- 1.16.1
- 1.17.0
- 1.17.1
- 1.17.2
- 1.2
- 1.3
- 1.4
- 1.5
- 1.6
- 1.7
- 1.8
- 1.9
- 2.0.0
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.1
Обновитесь до 2.0.1
wlc Ubuntu:Pro:18.04:LTS
- Версии
- 0.8-1
- 0.8-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wlc Ubuntu:Pro:20.04:LTS
- Версии
- 1.1-1
- 1.2-1
- 1.2-1ubuntu0.20.04.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wlc Ubuntu:Pro:22.04:LTS
- Версии
- 1.2-1
- 1.2-1ubuntu0.22.04.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wlc Ubuntu:Pro:24.04:LTS
- Версии
- 1.13-2
- 1.13-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wlc Ubuntu:26.10
- Версии
- 1.16.1-1
- 2.0.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wlc Ubuntu:26.04:LTS
- Версии
- 1.15-2
- 1.16.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления