p PatchFirst

CVE-2026-6270

CVE-2026-6270 · @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.

CVSS 9.1 · Критический · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • @fastify/middie

    Версии
    • ≥ 0, < 9.3.2: Затронуто (semver)
    • 9.3.2: Не затронуто (semver)

    Обновитесь до 9.3.2

  • @fastify/middie npm

    Затронутые диапазоны версий
    • SEMVER: < 9.3.2

    Обновитесь до 9.3.2

Первоисточники

Проверьте свой сервер →