CVE-2026-63383
CVE-2026-63383 · Libevent: decode_tag_internal() can lead to out-of-bounds read
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent can read beyond a contiguous evbuffer region in event_tagging.c when decode_tag_internal requests at most five bytes from evbuffer_pullup but iterates using the full logical buffer length. A fragmented evbuffer containing a six-byte malformed tag can therefore advance past the pullup window and trigger an out-of-bounds read, which can crash a process that decodes attacker-controlled tagged RPC data. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.
CVSS 8.7 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
libevent
- Версии
- >= 2.2.0-alpha, < 2.2.2-alpha: Затронуто
- < 2.1.13: Затронуто
Нет опубликованного исправления
libevent Debian:12
- Версии
- 2.1.12-stable-8
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.12-stable-8+deb12u1
Обновитесь до 2.1.12-stable-8+deb12u1
libevent Debian:13
- Версии
- 2.1.12-stable-10
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.13-stable-1~deb13u1
Обновитесь до 2.1.13-stable-1~deb13u1
libevent Debian:14
- Версии
- 2.1.12-stable-10
- 2.1.13-stable-1~deb13u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.13-stable-1
Обновитесь до 2.1.13-stable-1
libevent Ubuntu:Pro:14.04:LTS
- Версии
- 2.0.21-stable-1
- 2.0.21-stable-1ubuntu1
- 2.0.21-stable-1ubuntu1.14.04.1
- 2.0.21-stable-1ubuntu1.14.04.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.21-stable-1ubuntu1.14.04.2+esm1
Обновитесь до 2.0.21-stable-1ubuntu1.14.04.2+esm1
libevent Ubuntu:Pro:16.04:LTS
- Версии
- 2.0.21-stable-2
- 2.0.21-stable-2ubuntu0.16.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.21-stable-2ubuntu0.16.04.1+esm1
Обновитесь до 2.0.21-stable-2ubuntu0.16.04.1+esm1
libevent Ubuntu:Pro:18.04:LTS
- Версии
- 2.1.8-stable-4
- 2.1.8-stable-4build1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.8-stable-4ubuntu0.1~esm1
Обновитесь до 2.1.8-stable-4ubuntu0.1~esm1
libevent Ubuntu:Pro:20.04:LTS
- Версии
- 2.1.8-stable-4build1
- 2.1.11-stable-1~exp0
- 2.1.11-stable-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.11-stable-1ubuntu0.1~esm1
Обновитесь до 2.1.11-stable-1ubuntu0.1~esm1
libevent Ubuntu:22.04:LTS
- Версии
- 2.1.12-stable-1
- 2.1.12-stable-1build1
- 2.1.12-stable-1build2
- 2.1.12-stable-1build3
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.12-stable-1ubuntu0.1
Обновитесь до 2.1.12-stable-1ubuntu0.1
libevent Ubuntu:24.04:LTS
- Версии
- 2.1.12-stable-9
- 2.1.12-stable-9ubuntu2
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.12-stable-9ubuntu2.1
Обновитесь до 2.1.12-stable-9ubuntu2.1
libevent Ubuntu:26.04:LTS
- Версии
- 2.1.12-stable-10build1
- 2.1.12-stable-10build2
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.12-stable-10ubuntu0.1
Обновитесь до 2.1.12-stable-10ubuntu0.1
Первоисточники
- https://github.com/libevent/libevent/security/advisories/GHSA-fj29-64w6-73h6
- https://github.com/libevent/libevent/commit/91ed8745eebabdd27592a83d350338a8c4626321
- https://github.com/libevent/libevent/commit/e1f9e21887c6b104e206a718385ba3ffc75180cb
- https://github.com/libevent/libevent/releases/tag/release-2.1.13-stable
- https://github.com/libevent/libevent/releases/tag/release-2.2.2-alpha
- https://nvd.nist.gov/vuln/detail/CVE-2026-63383