CVE-2026-67327
CVE-2026-67327 · better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.
CVSS 8.7 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
better-auth
- Версии
- ≥ 1.1.3, < 1.6.22: Затронуто (semver)
- 1.6.22: Не затронуто (semver)
Обновитесь до 1.6.22
better-auth
- Версии
- ≥ 1.7.0-beta.0, < 1.7.0-beta.10: Затронуто (semver)
- 1.7.0-beta.10: Не затронуто (semver)
Обновитесь до 1.7.0-beta.10
better-auth npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.1.3, < 1.6.22
Обновитесь до 1.6.22
better-auth npm
- Затронутые диапазоны версий
- SEMVER: ≥ 1.7.0-beta.0, < 1.7.0-beta.10
Обновитесь до 1.7.0-beta.10