CVE-2026-67404
CVE-2026-67404 · RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
CVSS 9.2 · Критический · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
rabbitmq
- Версии
- >= 3.13.0, < 3.13.15: Затронуто
- >= 4.0.0, < 4.0.20: Затронуто
- >= 4.1.0, < 4.1.11: Затронуто
- >= 4.2.0, < 4.2.6: Затронуто
Нет опубликованного исправления
rabbitmq-server Debian:12
- Версии
- 3.10.8-1.1
- 3.10.8-1.1+deb12u1
- 3.10.8-2
- 3.10.8-3
- 3.10.8-4
- 3.12.1-1
- 3.12.1-1.1
- 4.0.5-1
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-2
- 4.0.5-3
- 4.0.5-4
- 4.0.5-5
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Debian:13
- Версии
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-6+deb13u1
- 4.0.5-6+deb13u2
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Debian:14
- Версии
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.3.0-2
Обновитесь до 4.3.0-2
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Версии
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.5.7-1ubuntu0.16.04.4+esm3
Обновитесь до 3.5.7-1ubuntu0.16.04.4+esm3
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Версии
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.6.10-1ubuntu0.5+esm1
Обновитесь до 3.6.10-1ubuntu0.5+esm1
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Версии
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.8.3-0ubuntu0.3+esm2
Обновитесь до 3.8.3-0ubuntu0.3+esm2
rabbitmq-server Ubuntu:22.04:LTS
- Версии
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- 3.9.13-1ubuntu0.22.04.2
- 3.9.27-0ubuntu0.1
- 3.9.27-0ubuntu0.2
- 3.9.27-0ubuntu0.5
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.9.27-0ubuntu0.6
Обновитесь до 3.9.27-0ubuntu0.6
rabbitmq-server Ubuntu:24.04:LTS
- Версии
- 3.12.1-1
- 3.12.1-1ubuntu1
- 3.12.1-1ubuntu1.2
- 3.12.1-1ubuntu1.4
- 3.12.1-1ubuntu1.6
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.12.1-1ubuntu1.7
Обновитесь до 3.12.1-1ubuntu1.7
rabbitmq-server Ubuntu:26.04:LTS
- Версии
- 4.0.5-8ubuntu2
- 4.0.5-10ubuntu1
- 4.0.5-10ubuntu2
- 4.0.5-10ubuntu3
- 4.0.5-10ubuntu4
- 4.0.5-10ubuntu5
- 4.0.5-10ubuntu5.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.0.5-10ubuntu5.2
Обновитесь до 4.0.5-10ubuntu5.2