CVE-2026-67418
CVE-2026-67418 · RabbitMQ MQTT 5: inapplicable PUBLISH property disconnects matching subscribers
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5, the MQTT 5 parser in deps/rabbitmq_mqtt/src/rabbit_mqtt_packet.erl accepts Request-Problem-Information on PUBLISH packets even though the property is valid only for CONNECT. An authenticated publisher with topic write permission can cause the broker to store and route that inapplicable property to a separately authenticated matching subscriber. When the subscriber path serializes the outbound PUBLISH, serialise_prop/2 has no matching clause, and the uncontained function_clause exception closes the victim MQTT or Web MQTT connection. The publisher connection and broker remain available, and queued replay, retained-message persistence, and broker-wide denial of service were not established. This issue is fixed in versions 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5.
CVSS 5.3 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
rabbitmq
- Версии
- >= 3.13.0, < 3.13.19: Затронуто
- >= 4.0.0, < 4.0.24: Затронуто
- >= 4.1.0, < 4.1.15: Затронуто
- >= 4.2.0, < 4.2.10: Затронуто
- >= 4.3.0, < 4.3.5: Затронуто
Нет опубликованного исправления
rabbitmq-server Debian:12
- Версии
- 3.10.8-1.1
- 3.10.8-1.1+deb12u1
- 3.10.8-2
- 3.10.8-3
- 3.10.8-4
- 3.12.1-1
- 3.12.1-1.1
- 4.0.5-1
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-2
- 4.0.5-3
- 4.0.5-4
- 4.0.5-5
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Debian:13
- Версии
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-6+deb13u1
- 4.0.5-6+deb13u2
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Debian:14
- Версии
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.3.6-1
Обновитесь до 4.3.6-1
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Версии
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- 3.5.7-1ubuntu0.16.04.4+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Версии
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- 3.6.10-1ubuntu0.5+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Версии
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- 3.8.3-0ubuntu0.3+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Ubuntu:22.04:LTS
- Версии
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- 3.9.13-1ubuntu0.22.04.2
- 3.9.27-0ubuntu0.1
- 3.9.27-0ubuntu0.2
- 3.9.27-0ubuntu0.5
- 3.9.27-0ubuntu0.6
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Ubuntu:24.04:LTS
- Версии
- 3.12.1-1
- 3.12.1-1ubuntu1
- 3.12.1-1ubuntu1.2
- 3.12.1-1ubuntu1.4
- 3.12.1-1ubuntu1.6
- 3.12.1-1ubuntu1.7
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Ubuntu:26.10
- Версии
- 4.0.5-10ubuntu5
- 4.3.2-4ubuntu2
- 4.3.2-4ubuntu3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
rabbitmq-server Ubuntu:26.04:LTS
- Версии
- 4.0.5-8ubuntu2
- 4.0.5-10ubuntu1
- 4.0.5-10ubuntu2
- 4.0.5-10ubuntu3
- 4.0.5-10ubuntu4
- 4.0.5-10ubuntu5
- 4.0.5-10ubuntu5.1
- 4.0.5-10ubuntu5.2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-jv99-v328-mvmm
- https://github.com/rabbitmq/rabbitmq-server/pull/17035
- https://github.com/rabbitmq/rabbitmq-server/pull/17287
- https://github.com/rabbitmq/rabbitmq-server/commit/4639a4318c72a0660e4bc014767fad70ce288fbc
- https://github.com/rabbitmq/rabbitmq-server/commit/908f944a1d581d10774f8d6d0dcf2a1a713779fb
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-67418