CVE-2026-67590
CVE-2026-67590 · Apache Qpid ProtonJ2: Unbounded type nesting can lead to pre-authentication stackoverflow
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
CVSS 7.5 · Высокий · EPSS 0,8%
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache qpid protonj2
- Версии
- ≥ 0, ≤ 1.1.0: Затронуто (semver)
Нет опубликованного исправления
qpid-proton Ubuntu:16.04:LTS
- Версии
- 0.7-2
- 0.10-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qpid-proton Ubuntu:18.04:LTS
- Версии
- 0.14.0-5.1
- 0.14.0-5.1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qpid-proton Ubuntu:20.04:LTS
- Версии
- 0.22.0-3.2
- 0.22.0-3.2build1
- 0.22.0-3.3
- 0.22.0-3.3build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qpid-proton Ubuntu:22.04:LTS
- Версии
- 0.22.0-5.1
- 0.22.0-5.1build1
- 0.22.0-5.1ubuntu1
- 0.22.0-5.1ubuntu2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qpid-proton Ubuntu:24.04:LTS
- Версии
- 0.37.0-2build1
- 0.37.0-2build2
- 0.37.0-2build4
- 0.37.0-2build5
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qpid-proton Ubuntu:26.10
- Версии
- 0.37.0-7build1
- 0.37.0-8
- 0.37.0-9
- 0.37.0-9build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qpid-proton Ubuntu:26.04:LTS
- Версии
- 0.37.0-6
- 0.37.0-6build1
- 0.37.0-7
- 0.37.0-7build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления