CVE-2026-69152
CVE-2026-69152 · brace-expansion: DoS via unbounded intermediate arrays, bypassing the CVE-2026-14257 mitigation
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.
CVSS 7.5 · Высокий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
brace-expansion
- Версии
- < 1.1.18: Затронуто
- >= 2.0.0, < 2.1.4: Затронуто
- >= 3.0.0, < 3.0.6: Затронуто
- >= 4.0.0, < 5.0.9: Затронуто
Нет опубликованного исправления
brace-expansion npm
- Затронутые диапазоны версий
- SEMVER: < 1.1.18
Обновитесь до 1.1.18
brace-expansion npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.1.4
Обновитесь до 2.1.4
brace-expansion npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.0.6
Обновитесь до 3.0.6
brace-expansion npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.0.0, < 5.0.9
Обновитесь до 5.0.9
node-brace-expansion Ubuntu:18.04:LTS
- Версии
- 1.1.8-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:20.04:LTS
- Версии
- 1.1.8-1
- 1.1.11-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:22.04:LTS
- Версии
- 2.0.0-1
- 2.0.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:24.04:LTS
- Версии
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:26.10
- Версии
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-brace-expansion Ubuntu:26.04:LTS
- Версии
- 2.0.1+~1.1.0-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-rgw5-rvv9-x895
- https://github.com/juliangruber/brace-expansion/commit/139d015104e71433ad52a41d19467c48ecbb2c7d
- https://github.com/juliangruber/brace-expansion/commit/1e30c930238d7162802d88a94189182def178dac
- https://github.com/juliangruber/brace-expansion/commit/688a99eeaab02627c2b89ba8ba4821fecfa659cf
- https://github.com/juliangruber/brace-expansion/commit/cb4b9e47cc2ec777c14b2b4492fb431a56f6a031
- https://nvd.nist.gov/vuln/detail/CVE-2026-69152