p PatchFirst

CVE-2026-71436

CVE-2026-71436 · Mermaid XY Charts are vulnerable to an infinite loop DoS

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.

CVSS 5.3 · Средний · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • mermaid

    Версии
    • >= 10.6.0, < 10.9.8: Затронуто
    • >= 11.0.0-alpha.1, < 11.16.1: Затронуто

    Нет опубликованного исправления

  • node-mermaid Debian:14

    Версии
    • 8.11.0+ds+~cs29.13.22-1
    • 8.13.2+ds+~cs30.13.21-1
    • 8.13.2+ds+~cs30.13.21-1.1
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    • 8.14.0+ds1+~cs11.4.14-1
    • 8.14.0+~cs11.4.14-1
    • 8.7.0+ds+~cs27.17.17-1
    • 8.7.0+ds+~cs27.17.17-2
    • 8.7.0+ds+~cs27.17.17-2~bpo10+1
    • 8.7.0+ds+~cs27.17.17-3
    • 8.9.1+ds+~cs26.20.25-1
    • 8.9.3+ds+~cs29.13.19-1
    • 9.2.2+~2.0.0-1
    • 9.2.2+~2.0.0-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • mermaid npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 10.6.0, < 10.9.8

    Обновитесь до 10.9.8

  • mermaid npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 11.0.0-alpha.1, < 11.16.1

    Обновитесь до 11.16.1

  • node-mermaid Ubuntu:22.04:LTS

    Версии
    • 8.7.0+ds+~cs27.17.17-3
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-mermaid Ubuntu:26.10

    Версии
    • 9.2.2+~2.0.0-1
    • 9.2.2+~2.0.0-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →