p PatchFirst

CVE-2026-73258

CVE-2026-73258 · Mongoose: Multipart boundary/header scan logic error in mg_http_next_multipart

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.

CVSS 6.5 · Средний · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • mongoose

    Версии
    • < 7.22: Затронуто

    Нет опубликованного исправления

  • mongoose Debian:14

    Версии
    • 7.21+ds-1
    • 7.21+ds-1~bpo13+1
    • 7.21+ds-2
    • 7.22+ds-1~bpo13+1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.22+ds-1

    Обновитесь до 7.22+ds-1

  • mongoose Ubuntu:26.10

    Версии
    • 7.21+ds-1
    • 7.21+ds-2
    • 7.22+ds-1
    • 7.23+ds-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →