p PatchFirst

CVE-2026-73483

CVE-2026-73483 · Flowise before 3.1.3 Sandbox Escape via Puppeteer

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.

CVSS 9.4 · Критический · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • flowise

    Версии
    • ≥ 0, < 3.1.3: Затронуто (semver)
    • 3.1.3: Не затронуто (semver)

    Обновитесь до 3.1.3

  • flowise npm

    Затронутые диапазоны версий
    • SEMVER: < 3.1.3

    Обновитесь до 3.1.3

  • flowise-components npm

    Затронутые диапазоны версий
    • SEMVER: < 3.1.3

    Обновитесь до 3.1.3

Первоисточники

Проверьте свой сервер →