p PatchFirst

CVE-2026-73557

CVE-2026-73557 · vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.

CVSS 6.3 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • vllm

    Версии
    • >= 0.20.2rc0, < 0.26.0: Затронуто

    Нет опубликованного исправления

  • vllm PyPI

    Версии
    • 0.21.0
    • 0.22.0
    • 0.22.1
    • 0.23.0
    • 0.24.0
    • 0.25.0
    • 0.25.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 0.21.0, < 0.26.0

    Обновитесь до 0.26.0

Первоисточники

Проверьте свой сервер →