p PatchFirst

CVE-2026-75857

CVE-2026-75857 · CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

CVSS 7.3 · Высокий · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • codewhale

    Версии
    • ≥ 0.3.10, ≤ 0.8.41: Затронуто (semver)

    Нет опубликованного исправления

  • codewhale

    Версии
    • ≥ 0.3.10, < 0.8.41: Затронуто (semver)
    • 0.8.41: Не затронуто (semver)

    Обновитесь до 0.8.41

  • codewhale

    Версии
    • ≥ 0.8.41, < 0.8.64: Затронуто (semver)
    • 0.8.64: Не затронуто (semver)

    Обновитесь до 0.8.64

  • deepseek-tui crates.io

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.3.10, ≤ 0.8.41

    Нет опубликованного исправления

  • deepseek-tui npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.3.10, < 0.8.41

    Обновитесь до 0.8.41

  • codewhale-tui crates.io

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Обновитесь до 0.8.64

  • codewhale npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Обновитесь до 0.8.64

Первоисточники

Проверьте свой сервер →