p PatchFirst

CVE-2026-75858

CVE-2026-75858 · CodeWhale rlm_eval before 0.8.64 Remote Code Execution

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

CVSS 8.5 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • codewhale

    Версии
    • ≥ 0.8.33, < 0.8.41: Затронуто (semver)
    • 0.8.41: Не затронуто (semver)

    Обновитесь до 0.8.41

  • codewhale

    Версии
    • ≥ 0.8.41, < 0.8.64: Затронуто (semver)
    • 0.8.64: Не затронуто (semver)

    Обновитесь до 0.8.64

  • deepseek-tui crates.io

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.33, ≤ 0.8.41

    Нет опубликованного исправления

  • deepseek-tui npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.33, < 0.8.41

    Обновитесь до 0.8.41

  • codewhale-tui crates.io

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Обновитесь до 0.8.64

  • codewhale npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Обновитесь до 0.8.64

Первоисточники

Проверьте свой сервер →