CVE-2026-75899
CVE-2026-75899 · fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.
CVSS 7.5 · Высокий · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
fast-uri
- Версии
- ≥ 2.4.1, < 2.4.5: Затронуто (semver)
- 2.4.5: Не затронуто (semver)
- ≥ 3.1.2, < 3.1.6: Затронуто (semver)
- 3.1.6: Не затронуто (semver)
- ≥ 4.0.0, < 4.1.3: Затронуто (semver)
- 4.1.3: Не затронуто (semver)
Обновитесь до 2.4.5; Обновитесь до 3.1.6; Обновитесь до 4.1.3
node-ajv Debian:13
- Версии
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- 8.20.0~ds+~cs7.1.4-1
- 8.20.0~ds+~cs7.1.5-1
- 8.20.0~ds+~cs7.1.6-1
- 8.20.0~ds+~cs7.1.6-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ajv Debian:14
- Версии
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.20.0~ds+~cs7.1.4-1
Обновитесь до 8.20.0~ds+~cs7.1.4-1
fast-uri npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.4.1, < 2.4.5
Обновитесь до 2.4.5
fast-uri npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.1.2, < 3.1.6
Обновитесь до 3.1.6
fast-uri npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.0.0, < 4.1.3
Обновитесь до 4.1.3
node-ajv Ubuntu:18.04:LTS
- Версии
- 5.0.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ajv Ubuntu:20.04:LTS
- Версии
- 6.10.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ajv Ubuntu:22.04:LTS
- Версии
- 6.12.6-2
- 6.12.6-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ajv Ubuntu:24.04:LTS
- Версии
- 6.12.6-3
- 8.12.0~ds+~2.1.1-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ajv Ubuntu:26.10
- Версии
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ajv Ubuntu:26.04:LTS
- Версии
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления