p PatchFirst

CVE-2026-75913

CVE-2026-75913 · CodeWhale before 0.8.64 Argument Injection via git_show

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

CVSS 8.5 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • codewhale

    Версии
    • ≥ 0.3.27, ≤ 0.8.41: Затронуто (semver)

    Нет опубликованного исправления

  • codewhale

    Версии
    • ≥ 0.3.27, < 0.8.41: Затронуто (semver)
    • 0.8.41: Не затронуто (semver)

    Обновитесь до 0.8.41

  • codewhale

    Версии
    • ≥ 0.8.41, < 0.8.64: Затронуто (semver)
    • 0.8.64: Не затронуто (semver)

    Обновитесь до 0.8.64

  • deepseek-tui crates.io

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.3.27, ≤ 0.8.41

    Нет опубликованного исправления

  • deepseek-tui npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.3.27, < 0.8.41

    Обновитесь до 0.8.41

  • codewhale-tui crates.io

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Обновитесь до 0.8.64

  • codewhale npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Обновитесь до 0.8.64

Первоисточники

Проверьте свой сервер →