CVE-2026-81719
CVE-2026-81719 · openssl_encrypt before 1.4.9 Remote Code Execution via Plugin
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.
CVSS 9.3 · Критический · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
openssl_encrypt
- Версии
- ≥ 0, < 1.4.9: Затронуто (semver)
- 1.4.9: Не затронуто (semver)
Обновитесь до 1.4.9
openssl-encrypt PyPI
- Версии
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.5.0
- 0.5.1
- 0.5.3
- 0.6.0rc1
- 0.7.0rc2
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.2
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.4.0
- 1.4.0b3
- 1.4.0b4
- 1.4.0b5
- 1.4.0b6
- 1.4.0b7
- 1.4.0b8
- 1.4.1
- 1.4.1rc2
- 1.4.2
- 1.4.4
- 1.4.5
- 1.4.6
- 1.4.7
- 1.4.8
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.4.9
Обновитесь до 1.4.9