CVE-2026-84307
CVE-2026-84307 · Filament: Password validity disclosure for accounts denied panel access on login page
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.12.5 and 5.7.5, packages/panels/src/Auth/Pages/Login.php presents the multi-factor authentication challenge before evaluating canAccessPanel(). For an account that canAccessPanel() denies, submitting the correct password renders the MFA challenge while an incorrect password returns the generic authentication failure, allowing an unauthenticated attacker to confirm whether a candidate password is valid for that account. When email-based MFA is configured, the correct-password path also sends a login code to the account holder. The issue applies only to accounts that have MFA enabled and are denied panel access. Authentication is not bypassed because canAccessPanel() still runs after the challenge, and no session is created. This issue is fixed in versions 4.12.5 and 5.7.5.
CVSS 3.7 · Низкий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
filament
- Версии
- >= 4.0.0, < 4.12.5: Затронуто
- >= 5.0.0, < 5.7.5: Затронуто
Нет опубликованного исправления
filament/filament Packagist
- Версии
- v4.0.0
- v4.0.1
- v4.0.10
- v4.0.11
- v4.0.12
- v4.0.13
- v4.0.14
- v4.0.15
- v4.0.16
- v4.0.17
- v4.0.18
- v4.0.19
- v4.0.2
- v4.0.20
- v4.0.3
- v4.0.4
- v4.0.5
- v4.0.6
- v4.0.7
- v4.0.8
- v4.0.9
- v4.1.0
- v4.1.1
- v4.1.10
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.1.6
- v4.1.7
- v4.1.8
- v4.1.9
- v4.10.0
- v4.10.1
- v4.10.2
- v4.11.0
- v4.11.1
- v4.11.2
- v4.11.3
- v4.11.4
- v4.11.5
- v4.11.6
- v4.11.7
- v4.11.8
- v4.12.0
- v4.12.0-beta1
- v4.12.0-beta2
- v4.12.0-beta3
- v4.12.0-beta4
- v4.12.1
- v4.12.2
- v4.12.3
- v4.12.4
- v4.2.0
- v4.2.1
- v4.2.2
- v4.2.3
- v4.2.4
- v4.3.0
- v4.3.1
- v4.4.0
- v4.5.0
- v4.5.1
- v4.5.2
- v4.5.3
- v4.6.0
- v4.6.1
- v4.6.2
- v4.6.3
- v4.7.0
- v4.7.1
- v4.7.2
- v4.7.3
- v4.7.4
- v4.8.0
- v4.8.1
- v4.8.2
- v4.8.3
- v4.8.4
- v4.8.5
- v4.9.0
- v4.9.1
- v4.9.2
- v4.9.3
- v4.9.4
- v4.9.5
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.0.0, < 4.12.5
Обновитесь до 4.12.5
filament/filament Packagist
- Версии
- v5.0.0
- v5.1.0
- v5.1.1
- v5.1.2
- v5.1.3
- v5.2.0
- v5.2.1
- v5.2.2
- v5.2.3
- v5.2.4
- v5.3.0
- v5.3.1
- v5.3.2
- v5.3.3
- v5.3.4
- v5.3.5
- v5.4.0
- v5.4.1
- v5.4.2
- v5.4.3
- v5.4.4
- v5.4.5
- v5.5.0
- v5.5.1
- v5.5.2
- v5.6.0
- v5.6.1
- v5.6.2
- v5.6.3
- v5.6.4
- v5.6.5
- v5.6.6
- v5.6.7
- v5.6.8
- v5.7.0
- v5.7.0-beta1
- v5.7.0-beta2
- v5.7.0-beta3
- v5.7.0-beta4
- v5.7.1
- v5.7.2
- v5.7.3
- v5.7.4
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 5.0.0, < 5.7.5
Обновитесь до 5.7.5
Первоисточники
- https://github.com/filamentphp/filament/security/advisories/GHSA-xwpv-pqxp-5v36
- https://github.com/filamentphp/filament/pull/20308
- https://github.com/filamentphp/filament/commit/ad5aacbc6d089b3dd7243ec1c1f8ab19dff7c3a1
- https://github.com/filamentphp/filament/releases/tag/v4.12.5
- https://github.com/filamentphp/filament/releases/tag/v5.7.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-84307