CVE-2026-86431
CVE-2026-86431 · commonmark before 2.9.1 XSS via AttributesExtension form feed bypass
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
league/commonmark (thephpleague/commonmark) versions >= 2.7.0 and < 2.9.1 contain a cross-site scripting vulnerability in the AttributesExtension. Prefixing an attribute name with a single U+000C form feed byte (e.g. {\x0Conclick="alert(1)"}) bypasses the AttributesHelper::filterAttributes() 'on*' event-handler filter because PHP's trim() does not strip U+000C, causing the attribute to be written verbatim into the output where browsers parse it as a genuine event handler. The same prefix also defeats the allow_unsafe_links check, allowing javascript: URIs through href/src attributes even when allow_unsafe_links is false. Exploitation requires processing untrusted Markdown with the AttributesExtension enabled; the injected script executes when the rendered HTML is viewed. Fixed in 2.9.1.
CVSS 6.9 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
commonmark
- Версии
- ≥ 2.7.0, < 2.9.1: Затронуто (semver)
- 2.9.1: Не затронуто (semver)
Обновитесь до 2.9.1
php-league-commonmark Debian:12
- Версии
- 2.10.0-1
- 2.10.1-1
- 2.10.3-1
- 2.3.9-1
- 2.3.9-1+deb12u1
- 2.4.0-1
- 2.4.1-1
- 2.4.2-1
- 2.4.2-2
- 2.5.0-1
- 2.5.1-1
- 2.5.3-1
- 2.6.0-1
- 2.6.1-1
- 2.6.1-2
- 2.6.2-1
- 2.7.0-1
- 2.7.1-1
- 2.7.1-2
- 2.8.0-1
- 2.8.1-1
- 2.8.2-1
- 2.8.2-2
- 2.8.3-1
- 2.9.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
php-league-commonmark Debian:13
- Версии
- 2.10.0-1
- 2.10.1-1
- 2.10.3-1
- 2.7.0-1
- 2.7.0-1+deb13u1
- 2.7.1-1
- 2.7.1-2
- 2.8.0-1
- 2.8.1-1
- 2.8.2-1
- 2.8.2-2
- 2.8.3-1
- 2.9.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
php-league-commonmark Debian:14
- Версии
- 2.7.0-1
- 2.7.1-1
- 2.7.1-2
- 2.8.0-1
- 2.8.1-1
- 2.8.2-1
- 2.8.2-2
- 2.8.3-1
- 2.9.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.10.0-1
Обновитесь до 2.10.0-1
league/commonmark Packagist
- Версии
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.9.0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 2.7.0, < 2.9.1
Обновитесь до 2.9.1
php-league-commonmark Ubuntu:Pro:20.04:LTS
- Версии
- 1.1.2-1
- 1.2.0-1
- 1.3.0-1
- 1.3.1-1
- 1.3.1-1ubuntu2
- 1.3.1-1ubuntu2+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
php-league-commonmark Ubuntu:Pro:22.04:LTS
- Версии
- 1.5.7-2build1
- 1.6.6-1build1
- 1.6.7-1
- 1.6.7-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
php-league-commonmark Ubuntu:Pro:24.04:LTS
- Версии
- 2.3.9-1
- 2.4.1-1
- 2.4.2-1
- 2.4.2-2
- 2.4.2-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
php-league-commonmark Ubuntu:26.04:LTS
- Версии
- 2.7.0-1
- 2.7.1-2
- 2.8.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/thephpleague/commonmark/security/advisories/GHSA-f8fg-pg57-v4j8
- https://github.com/thephpleague/commonmark/commit/43207253ea5f14867c77c697cd3838c446cadcea
- https://www.vulncheck.com/advisories/commonmark-before-2.9.1-xss-via-attributesextension-form-feed-bypass
- https://nvd.nist.gov/vuln/detail/CVE-2026-86431